MyBBDepo - Türkiyenin MyBB Deposu Forumuna Hoşgeldiniz
Eğer sitemize yaptığınız ilk ziyaretiniz ise, lütfen öncelikle Forum Kurallarını okuyunuz. Forumumuzda bilgi alışverişinde bulunabilmeniz için Kayıt olmalısınız. Üye olmayanlar forumumuzdan yararlanamazlar.
Eğer zaten kayıtlı kullanıcı iseniz, lütfen kullanıcı adınız ve şifreniz ile, Giriş yapınız. (Sitemize üyelik ücretsizdir).
#Zavira avatar
Konuyu Oyla:
  • Derecelendirme: 0/5 - 0 oy
  • 1
  • 2
  • 3
  • 4
  • 5

Derecelendirme: 0/5 - 0 oy

Güncelleme sonrası hata - Moderasyon İşlemi için herhangi bir konu seçmediniz


Sponsor Reklam

Çevrimdışı #Zavira
 Tarih: 20-03-2019, Saat:15:57
#9
Bu arada ben forumu 1813 versiyonundan 1820 versiyonuna kadar ftpden attım upgrade.php ile güncelledim.
bu şekilde temamı hiç güncellemedim her versiyonda. güncellemem gerekir mi acaba?
Cevapla
Bunu Beğenenler:

İzinli devmybb
 Tarih: 20-03-2019, Saat:17:04
(Son Düzenleme: 20-03-2019, Saat:17:07, Düzenleyen: devmybb.)
#10
Şablon güncellemeleri her versiyonda olabiliyor. Özel kullandığınız Temanızın şablonlarının içeriğindeki kodlamalar değişik olabileceğinden dolayı her upgrade şeklindeki otomatik versiyon güncellemesinde şablon içeriği değiştirilemeyebilir. Onun için temalarınızın güncellemesini manuel yapmak zorundasınız. Altta verdiğim linkten Blame veya History sekmesine girip kod(9777787) şeklinde görünen düzenleme linkinde gösterilen değişiklikleri şablon içeriklerinizi kontrol edip temanıza uygulayabilirsiniz.
Kod:
https://github.com/mybb/mybb/blob/bc5fcf4d3855b754a422e633effaa0466d198bd3/install/resources/mybb_theme.xml

Aldığınız bu moderation hatası için sanırım  headerinclude şablonu içerisinde olmayan kod satırından kaynaklanıyor. Bu şablona girin;
Bul:
Kod:
var cookiePrefix = "{$mybb->settings['cookieprefix']}";
Alta satır açıp ekle:
Kod:
var cookieSecureFlag = "{$mybb->settings['cookiesecureflag']}";
Cevapla
Bunu Beğenenler: #Zavira

Çevrimdışı #Zavira
 Tarih: 20-03-2019, Saat:17:22
#11
(20-03-2019, Saat:17:04)devmybb Adlı Kullanıcıdan Alıntı: Şablon güncellemeleri her versiyonda olabiliyor. Özel kullandığınız Temanızın şablonlarının içeriğindeki kodlamalar değişik olabileceğinden dolayı her upgrade şeklindeki otomatik versiyon güncellemesinde şablon içeriği değiştirilemeyebilir. Onun için temalarınızın güncellemesini manuel yapmak zorundasınız. Altta verdiğim linkten Blame veya History sekmesine girip kod(9777787) şeklinde görünen düzenleme linkinde gösterilen değişiklikleri şablon içeriklerinizi kontrol edip temanıza uygulayabilirsiniz.
Kod:
https://github.com/mybb/mybb/blob/bc5fcf4d3855b754a422e633effaa0466d198bd3/install/resources/mybb_theme.xml

Aldığınız bu moderation hatası için sanırım  headerinclude şablonu içerisinde olmayan kod satırından kaynaklanıyor. Bu şablona girin;
Bul:
Kod:
var cookiePrefix = "{$mybb->settings['cookieprefix']}";
Alta satır açıp ekle:
Kod:
var cookieSecureFlag = "{$mybb->settings['cookiesecureflag']}";

Çok teşekkürler 

Blame sekmesine giremedim site çöküyor ancak history sekmesinden giriş yapabildim.
Verdiğiniz kod ile ctrl + f araması yapıp kodun üzerine tıkladığım açılan sayfada
1820 yerine 1821 yazmamız gerektiği söyleniyor onu 1820 yaptım 1821 yapmalı mıyım?
ayrıca aynı sayfada "allowclear" diye bir kod eklenmesi yapmamız gerektiği söyleniyor.
temamın xml dosyasında multiple: false, olarak arama yaptım ve ilk çıkan yerin altına allowclear kodunu ekledim.
Resimde attığım kodda multiple false kısmı bir çok satırda olduğu için hepsine eklemedim ilk gelen satıra koydum doğru mu yapmışım acaba?
resim

 


Hatanın çözümünü de sunmuşsunuz umarım o da olur.
Cevapla
Bunu Beğenenler:

Çevrimdışı tedem
 Tarih: 20-03-2019, Saat:17:48
#12
Son yaptığınız düzenleme henüz çıkmamış olan 1.8.21 versiyonun düzenlemesidir.

Size her yükseltme işleminden sonra tema güncellemesi yapmak için farklı bir yol sunayım.

Adım 1: Yükselttiğiniz versiyonun bir alt versiyonunu localhost üzerinde kurun. (Örnek: Yükselttiğiniz versiyon 1.8.20, sizin localhost üzerinde kurmanız gereken versiyon 1.8.19 olmalıdır.)

Adım 2: Güncelleme yapmak istediğiniz temanın değişen şablonlarını bulun. (Yönetici Paneli -> Temalar & Şablonlar -> Şablonlar -> "Güncellenen Şablonları Bul" bölümünden.)

Adım 3: "Adım 2" sırasında tespit ettiğiniz şablonları, kendi sitenizin ve localhost üzerinde kurduğunuz bir önceki versiyonun varsayılan teması üzerinde (tek tek) açın. Bir önceki ile şimdiki versiyon arasındaki değişiklikleri tespit edin ve kullandığınız/güncelleme yapmak istediğiniz temaya uygulayın. Şablonlar arasındaki değişikliliği daha kolay tespit edebilmek için Diffchecker kullanabilirsiniz.
Cevapla
Bunu Beğenenler: #Zavira

 


Konu ile Alakalı Benzer Konular
Konular Yazar Yorumlar Okunma Son Yorum
Üzgün [1.8] (YARDIM) 1.8.20 GUNCELLEME // HATALAR ACIL DESTEK ! SERHATST 1 70 Dün, Saat:02:07
Son Yorum: SERHATST
Şiddet - Korku [MCTR - 1.8] İndex de HATA ! Enigma 4 128 13-05-2019, Saat:06:26
Son Yorum: novruz
  Yeni Konu Açarken 1364 Hatası Alıyorum Yardımcı Olurmusunuz ? batuhanbarut 3 137 30-04-2019, Saat:18:16
Son Yorum: EmreKarakaya
  [1.8] Ncode eklentisi hata veriyor. #Zavira 4 135 27-04-2019, Saat:18:42
Son Yorum: #Zavira
  [1.8] Siteye girerken hata AwpSlayer 4 110 24-04-2019, Saat:23:42
Son Yorum: EmreKarakaya



Konuyu Okuyanlar: 1 Ziyaretçi