MyBBDepo - Türkiyenin MyBB Deposu Forumuna Hoşgeldiniz
Eğer sitemize yaptığınız ilk ziyaretiniz ise, lütfen öncelikle Forum Kurallarını okuyunuz. Forumumuzda bilgi alışverişinde bulunabilmeniz için Kayıt olmalısınız. Üye olmayanlar forumumuzdan yararlanamazlar.
Eğer zaten kayıtlı kullanıcı iseniz, lütfen kullanıcı adınız ve şifreniz ile, Giriş yapınız. (Sitemize üyelik ücretsizdir).
casus916 avatar
Konuyu Oyla:
  • Derecelendirme: 1/5 - 1 oy
  • 1
  • 2
  • 3
  • 4
  • 5

Derecelendirme: 1/5 - 1 oy

Google Chromeda Türkçe Karakter Sorunu


Sponsor Reklam
media venus

Çevrimdışı casus916
 Tarih: 19-02-2014, Saat:14:57
(Son Düzenleme: 19-02-2014, Saat:14:58, Düzenleyen: casus916.)
#1
Merhaba arkadaşlar sitemi chrome ile görüntülemek istediğimde sadece anasayfadaki türkçe karakterlerde sorun oluşuyor. Firefox ve Explorer de görüntülemede sıkıntı yok.

Site adresi : http://www.donanimservisi.com

Admin panelinde UTF 8 dönüştürmede UTF 8 bütün tablolarda onaylı görünüyor. 4-Baytlık UTF-8 Desteği MySQL 5.5.3 versiyonu olmadığı için dönüştüremiyorum. Hosting firmamın MySQL sürümü 5.1.71
Cevapla
Bunu Beğenenler:
Sponsor Reklam
sponsor reklam sponsor reklam

Çevrimdışı usameavci
 Tarih: 19-02-2014, Saat:15:18
#2
Hata tarayıcı kaynaklı büyük ihtimal ile sitenizle alakalı bir sorun olduğunu sanmıyorum. Tarayıcnın karakter kodlamasını UTF-8 seçerek dener misiniz Melek - Masum
Cevapla
Bunu Beğenenler: casus916

Çevrimdışı casus916
 Tarih: 19-02-2014, Saat:15:27
#3
(19-02-2014, Saat:15:18)TShujin Adlı Kullanıcıdan Alıntı: Hata tarayıcı kaynaklı büyük ihtimal ile sitenizle alakalı bir sorun olduğunu sanmıyorum. Tarayıcnın karakter kodlamasını UTF-8 seçerek dener misiniz Melek - Masum

5-6 farklı bilgisayarda girip denedim hepsinde aynı sizde girmeyi denermisiniz nasıl görünüyor sizin tarayıcınızda.
Cevapla
Bunu Beğenenler:

Çevrimdışı usameavci
 Tarih: 19-02-2014, Saat:15:44
(Son Düzenleme: 19-02-2014, Saat:15:48, Düzenleyen: usameavci.)
#4
Denedim şimdi aynen sorun var. Ama dediğim gibi tarayıcı kaynaklı. Sağdaki menü butonuna basın orada araçlar sekmeside kodlama var. Varsayılan olarak Türkçe ayarlanmış. Onu En üstteki Otomatik Algıla yap. Sorunun düzelir.

Bu arada şablonlarında hatalar var. HTML etiketinden önce stil kodları eklemişsin. green yellow falan onları header_include şablonuna alıp bir dener misin. Onlardan dolayı karakter setini okumuyor olabilir.
Cevapla
Bunu Beğenenler: casus916

Çevrimdışı casus916
 Tarih: 19-02-2014, Saat:16:05
(Son Düzenleme: 19-02-2014, Saat:16:05, Düzenleyen: casus916.)
#5
Otomatik algıla yaptım düzeldi.

Bu konularda pek iyi değilim headerinclude şablonumun içeriği aşağıda yardımcı olursan sevinirim.

Kod:
<base href="{$settings['bburl']}/" />
<link&nbsp;rel="shortcut&nbsp;icon"&nbsp;href="favicon.ico"&nbsp;/>
{$metadescription}
{$metakeywords}
<link rel="alternate" type="application/rss+xml" title="{$lang->latest_threads} (RSS 2.0)" href="{$mybb->settings['bburl']}/syndication.php" />
<link rel="alternate" type="application/atom+xml" title="{$lang->latest_threads} (Atom 1.0)" href="{$mybb->settings['bburl']}/syndication.php?type=atom1.0" />
<meta name="description" content="Bilgisayar, notebook, yazıcı ve diğer çevre bileşenleri ile ilgili tüm donanım, yazılım sorunlarınıza çözüm bulabileceğiniz teknoloji sitesi." />
<meta name="keywords" content="donanim, bilgisayar, yazıcı, teknik servis, telefon, nokia, hp, asus, tamir" />
<meta http-equiv="Content-Type" content="text/html; charset={$charset}" />
<meta http-equiv="Content-Script-Type" content="text/javascript" />
<script type="text/javascript" src="{$mybb->settings['bburl']}/jscripts/prototype.js?ver=1603"></script>
<script type="text/javascript" src="{$mybb->settings['bburl']}/jscripts/general.js?ver=1603"></script>
<script type="text/javascript" src="{$mybb->settings['bburl']}/jscripts/popup_menu.js?ver=1600"></script>
{$stylesheets}
<script type="text/javascript">
<!--
    var cookieDomain = "{$mybb->settings['cookiedomain']}";
    var cookiePath = "{$mybb->settings['cookiepath']}";
    var cookiePrefix = "{$mybb->settings['cookieprefix']}";
    var deleteevent_confirm = "{$lang->deleteevent_confirm}";
    var removeattach_confirm = "{$lang->removeattach_confirm}";
    var loading_text = '{$lang->ajax_loading}';
    var saving_changes = '{$lang->saving_changes}';
    var use_xmlhttprequest = "{$mybb->settings['use_xmlhttprequest']}";
    var my_post_key = "{$mybb->post_code}";
    var imagepath = "{$theme['imgdir']}";
// -->
</script>
<script type="text/javascript" src="jscripts/thx.js"></script><script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-34172198-1']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>{$newpmmsg}
Cevapla
Bunu Beğenenler:

Çevrimdışı usameavci
 Tarih: 19-02-2014, Saat:16:08
#6
o kodları büyük ihtimal ile index şablonuna yada header şablonuna eklemişsin. Bir kontrol eder misin Melek - Masum
Cevapla
Bunu Beğenenler: casus916

Çevrimdışı casus916
 Tarih: 19-02-2014, Saat:16:17
#7
(19-02-2014, Saat:16:08)TShujin Adlı Kullanıcıdan Alıntı: o kodları büyük ihtimal ile index şablonuna yada header şablonuna eklemişsin. Bir kontrol eder misin Melek - Masum

Kusura bakma çok anlamadığım için şablonların içeriğini kopyalıyorum.

Header şablonum.

Kod:
<div id="container">
        <a name="top" id="top"></a>
        <div id="header">
            <div class="logo"><a href="{$mybb->settings['bburl']}/index.php"><img src="{$theme['logo']}" alt="{$mybb->settings['bbname']}" title="{$mybb->settings['bbname']}" /></a></div>
            <div class="menu">
                <ul>
                    <li><a href="{$mybb->settings['bburl']}/search.php"><img src="{$theme['imgdir']}/toplinks/search.gif" alt="" title="" />{$lang->toplinks_search}</a></li>
                    <li><a href="{$mybb->settings['bburl']}/memberlist.php"><img src="{$theme['imgdir']}/toplinks/memberlist.gif" alt="" title="" />{$lang->toplinks_memberlist}</a></li>
                    <li><a href="{$mybb->settings['bburl']}/calendar.php"><img src="{$theme['imgdir']}/toplinks/calendar.gif" alt="" title="" />{$lang->toplinks_calendar}</a></li>
                    <li><a href="{$mybb->settings['bburl']}/misc.php?action=help"><img src="{$theme['imgdir']}/toplinks/help.gif" alt="" title="" />{$lang->toplinks_help}</a></li>
                </ul>
            </div>
            <hr class="hidden" />
            <div id="panel">
                {$welcomeblock}
            </div>
        </div>
        <hr class="hidden" />
        <br class="clear" />
        <div id="content">
            {$pm_notice}
            {$bannedwarning}
            {$bbclosedwarning}
            {$unreadreports}
            {$pending_joinrequests}
            <navigation>
            <br />
</div>

İndex şablonum.

Kod:
<html>
<head>
<meta name="google-site-verification" content="rqXXXS4OVU1zCoi-THIUcztydZp7J_fPwCPseURpPWw" />
<title>{$mybb->settings['bbname']}</title>
{$headerinclude}
<script type="text/javascript">
<!--
    lang.no_new_posts = "{$lang->no_new_posts}";
    lang.click_mark_read = "{$lang->click_mark_read}";
// -->
</script>
</head>
<body>
{$header}{$myannouncements}
{$overview}
{$forums}
{$boardstats}

<dl class="forum_legend smalltext">
    <dt><img src="{$theme['imgdir']}/on.gif" alt="{$lang->new_posts}" title="{$lang->new_posts}" style="vertical-align: middle; padding-bottom: 4px;" /></dt>
    <dd>{$lang->new_posts}</dd>

    <dt><img src="{$theme['imgdir']}/off.gif" alt="{$lang->no_new_posts}" title="{$lang->no_new_posts}" style="vertical-align: middle; padding-bottom: 4px;" /></dt>
    <dd>{$lang->no_new_posts}</dd>

    <dt><img src="{$theme['imgdir']}/offlock.gif" alt="{$lang->forum_locked}" title="{$lang->forum_locked}" style="vertical-align: middle;" /></dt>
    <dd>{$lang->forum_locked}</dd>
</dl>
<br style="clear: both" />
{$footer}
</body>
</html>

Forum yaşı eklentisi vardı en son onu kaldırmıştım daha sonra bir arkadaş chrome da karakter sorunu olduğunu söyledi. Ondanda kaynaklı olabilir mi?
Cevapla
Bunu Beğenenler:

Çevrimdışı usameavci
 Tarih: 19-02-2014, Saat:16:21
#8
Bunlarda yok o kodları bulman lazım. Zahmet olmazsa şablonları bir gezer misin .yellow olarak arama yap şablonlarda çıkarsa eğer o şablonu buraya yazarsın. Çıkmazsa akşama TeamViewer'dan bakarım Melek - Masum
Cevapla
Bunu Beğenenler: casus916

 


Konu ile Alakalı Benzer Konular
Konular Yazar Yorumlar Okunma Son Yorum
  MyBB Saat Sorunu iCarly 9 356 07-11-2016, Saat:13:13
Son Yorum: iCarly
SSS Siteye eklenti kuramama sorunu ercoxx 0 140 21-08-2016, Saat:12:00
Son Yorum: ercoxx
  [1.6] Üye Giriş Sorunu Reis00 6 209 02-07-2016, Saat:18:51
Son Yorum: Reis00
Üzgün Üyelik şartları gibi Türkçe ikazların kaynağı ATABEY 1 369 07-06-2016, Saat:22:17
Son Yorum: ozanakkaya
Üzgün Kod da Hata Var Sorunu Çözdüm TolgaTSN 1 361 11-05-2016, Saat:22:26
Son Yorum: TolgaTSN



Konuyu Okuyanlar: 1 Ziyaretçi