MyBBDepo - Türkiyenin MyBB Deposu Forumuna Hoşgeldiniz
Eğer sitemize yaptığınız ilk ziyaretiniz ise, lütfen öncelikle Forum Kurallarını okuyunuz. Forumumuzda bilgi alışverişinde bulunabilmeniz için Kayıt olmalısınız. Üye olmayanlar forumumuzdan yararlanamazlar.
Eğer zaten kayıtlı kullanıcı iseniz, lütfen kullanıcı adınız ve şifreniz ile, Giriş yapınız. (Sitemize üyelik ücretsizdir).
childben6 avatar
Konuyu Oyla:
  • Derecelendirme: 1/5 - 1 oy
  • 1
  • 2
  • 3
  • 4
  • 5

Derecelendirme: 1/5 - 1 oy

Forum Buton Sorunu [ Düzenle ve Sil Butonları ]


Sponsor Reklam
media venus

Çevrimdışı childben6
 Tarih: 26-05-2013, Saat:21:58
(Son Düzenleme: 26-05-2013, Saat:23:54, Düzenleyen: childben6.)
#1
Web site Site Adresi :
Kod:
frmgenclik.com
Versiyon MyBB Sürümü : 1.6.10
Eklenti-Plugin Kurulu Eklentiler : Eklentilerle ilgili bir sorun değil
Hata-Sorun Sorun açıklaması :

Dün açtığım Forum buton sorunu adlı konudaki çözümleri deneyerek sorunu çözdüm. Butonları kodladım. ( alıntı , e posta vs.. ) Fakat bir türlü düzenle ve sil butonlarını kodlayamadım.

Aşağıdaki kodun üst satırına class="probuton kodunu ekleyerek kodladım. Ama sadece kendi yazdığım yorumun altındaki sil seçeneği buton şeklinde çıkıyor. Başkasının yorumunu silerken buton şekliyle değil eski haliyle ( resim ) çıkıyor.

postbit_quickdelete kodları :

Kod:
<a rel="nofollow" href="editpost.php?pid={$post['pid']}" onclick="Thread.deletePost({$post['pid']}); return false;" style="display: none;" id="quick_delete_{$post['pid']}" class="probuton" alt="{$lang->postbit_qdelete}" title="{$lang->postbit_qdelete}" ><img src="images/turkish/delete.png"/>SİL</a>

<script type="text/javascript">
// <!--
    $('quick_delete_{$post['pid']}').style.display = '';
// -->
</script>

---

Düzenle seçeneğini de buton halinde yaptım. Fakat sadece üyelere oluyor. Mesela üye yorum yazıyor düzenlerken yeni halini yani butonlu halini görüyor. Fakat yetkililere gözüken düzenle kısmı buton şeklini almıyor

postbit_edit kodları :

Kod:
<a rel="nofollow" href="editpost.php?pid={$post['pid']}" id="edit_post_{$post['pid']}" class="probuton" alt="{$lang->postbit_edit}" title="{$lang->postbit_edit}"><img src="images/turkish/duzenle.png"/>Düzenle</a>
<div id="edit_post_{$post['pid']}_popup" class="popup_menu" style="display: none;"><div class="popup_item_container"><a href="javascript:;" onclick="Thread.quickEdit({$post['pid']});" class="popup_item">{$lang->postbit_quick_edit}</a></div><div class="popup_item_container"><a href="editpost.php?pid={$post['pid']}" class="popup_item">{$lang->postbit_full_edit}</a></div></div>
<script type="text/javascript">
// <!--
    if(use_xmlhttprequest == "1")
    {
        new PopupMenu("edit_post_{$post['pid']}");
    }
// -->
</script>

Sadece bu ikisi kaldı nasıl çözelebiliriz ?
Cevapla
Bunu Beğenenler:
Sponsor Reklam
sponsor reklam sponsor reklam

Çevrimdışı benbuyum38
 Tarih: 26-05-2013, Saat:22:16
#2
Şablona uyunuz !
Cevapla
Bunu Beğenenler:

Çevrimdışı childben6
 Tarih: 26-05-2013, Saat:22:20
#3
(26-05-2013, Saat:22:16)benbuyum38 Adlı Kullanıcıdan Alıntı: Şablona uyunuz !

Unutmuşum , güncelllendi.
Cevapla
Bunu Beğenenler:

Çevrimdışı childben6
 Tarih: 27-05-2013, Saat:15:01
#4
Sorun hala çözülememiştir. Bilen yok mu ?
Cevapla
Bunu Beğenenler:

Çevrimdışı childben6
 Tarih: 28-05-2013, Saat:00:44
#5
Flood yapmak gibi olmasın ama ,

2 gündür destek bekliyorum , rapor ediyorum bir sonuç yok. İlgilenirseniz sevinirim.
Cevapla
Bunu Beğenenler:

 


Konu ile Alakalı Benzer Konular
Konular Yazar Yorumlar Okunma Son Yorum
  Mybb 1.6.15 Sürümünde Admin Paneli Beyaz Sayfa Sorunu grkm4 2 937 14-09-2014, Saat:18:35
Son Yorum: grkm4
  resim boyutlandırıcı sorunu guveniyorum 4 1,015 10-09-2014, Saat:21:44
Son Yorum: guveniyorum
  Selamun Aleyküm Forum yazısı editleme yardım darkpasha 1 1,665 07-09-2014, Saat:16:27
Son Yorum: eatik
  Özel Mesaj Alıntı Sorunu LeBeta™ 5 828 02-09-2014, Saat:10:51
Son Yorum: LeBeta™
  [MCTR - 1.6] video sorunu KaTRe 5 921 02-09-2014, Saat:03:38
Son Yorum: KaTRe



Konuyu Okuyanlar: 1 Ziyaretçi